VERSION ACTUAL :

Inicio de sesión

Raulito el Friki

Raulito El Friki

COMENTARIOS

EN LINEA

Hay actualmente 0 usuarios conectados.

NUEVOS

  • Pelydas
  • rugamu
  • erickalvarez73
  • fedegonzaga
  • lobo357

Se encuentra usted aquí

[Solucionado] Multifuncional Canon Pixma MG2100 cancela las impresiones

Imagen de apolo_xdes
Forums: 

Disculpen tal vez el titulo no sea el correcto pero paso a explicarme:
Hace poco obtuve una multifuncional, la cual he mencionado antes, al llegar a casa la conecte, fedora reconocio, pero no trabaja, la tengo asi desde hace unos 3 dias.
Cada vez que quiero imprimir me aparece un mensaje que dice: "Impresion cancelada", todo eso apesar que que aparece como impresora.
Les explico en lo que tengo en PC para ver si me pueden ayudar:
Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
Fedora 16 verne GNOME3
Kernel Linux 3.3.4-3.fc16.i686
RAM 4 GB
HDD 500 GB

Imagen de galania

cuando envies a imprimir copia la lectura del log :
como root:
tail -f /var/log/messages

aparecerá el posible error

Imagen de apolo_xdes

May 9 20:06:17 localhost dbus[1127]: [system] Successfully activated service 'org.freedesktop.PackageKit'
May 9 20:06:17 localhost dbus-daemon[1127]: dbus[1127]: [system] Successfully activated service 'org.freedesktop.PackageKit'
May 9 20:07:56 localhost dbus[1127]: [system] Activating service name='net.reactivated.Fprint' (using servicehelper)
May 9 20:07:56 localhost dbus-daemon[1127]: dbus[1127]: [system] Activating service name='net.reactivated.Fprint' (using servicehelper)
May 9 20:07:56 localhost dbus-daemon[1127]: Launching FprintObject
May 9 20:07:56 localhost dbus[1127]: [system] Successfully activated service 'net.reactivated.Fprint'
May 9 20:07:56 localhost dbus-daemon[1127]: dbus[1127]: [system] Successfully activated service 'net.reactivated.Fprint'
May 9 20:07:56 localhost dbus-daemon[1127]: ** Message: D-Bus service launched with name: net.reactivated.Fprint
May 9 20:07:56 localhost dbus-daemon[1127]: ** Message: entering main loop
May 9 20:08:27 localhost dbus-daemon[1127]: ** Message: No devices in use, exit

Imagen de apolo_xdes

Cuando intente volver a instalar la impresora mientras lo detectaba me tiro el siguiente mensaje:
FirewallD no está en ejecución. La detección de impresoras de red necesita que los servicios mdns, ipp, ipp-client y samba-client estén activados en el cortafuegos.
Busque en el firewall activar los servicios que me indico pero soy muy inexperto en esto y tal vez y lo he echo mal... preferiria saber como activarlos por consola y ver si por fin hago que funcione la multifuncional

Imagen de galania

#service iptables stop

sin el # ese es el prompt de root y prueba lanzar la impresion

Imagen de Fabianpa

con system-config-firewall se pueden abrir esos puertos facilmente

Imagen de apolo_xdes

Bueno ejecute el comando system-config-firewall pero en este caso para desactivar el firewall y despues instalar firewalld con lo cual el segundo mensaje ya no aparecio, luego decidi cambiar los driver a uno que encontre, despues de estos dias de estar en internet, para sorpresa no estaban en la pagian de Canon pero me sirvio, despues de configurar el firewall ya logre la imprimir.
Ahora bien los drivers de Canon que encontre son para la impresora y el escaner pero lo logro escanear ... ¿Que puedo hacer?

Imagen de apolo_xdes

Quiero darles las gracias por su apoyo con el problema de la impresora, y decirles que aun no logro que funcione el sacnner al ejecutar sane-find-scanner en el terminal me di oeste mensaje:
# sane-find-scanner will now attempt to detect your scanner. If the
# result is different from what you expected, first make sure your
# scanner is powered up and properly connected to your computer.

# No SCSI scanners found. If you expected something different, make sure that
# you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04a9 [Canon], product=0x1751 [MG2100 series]) at libusb:002:004
# Your USB scanner was (probably) detected. It may or may not be supported by
# SANE. Try scanimage -L and read the backend's manpage.

# Not checking for parallel port scanners.

# Most Scanners connected to the parallel port or other proprietary ports
# can't be detected by this program.
¿Alguien sabes cual es la solución?

Imagen de apolo_xdes

Ahora el scaner no se puede utilizar con xsane o simplescan, sin embargo con VueScan si lo gestiona y va todo bien lo unico que no me gusta es que debo pagar por el programa.